Flashing gear indicator???

Discussion in '7th Generation 2010-Present' started by som2002, May 26, 2018.

  1. som2002

    som2002 New Member

    Country:
    United States
    Joined:
    May 26, 2018
    Messages:
    13
    Likes Received:
    4
    Trophy Points:
    3
    Location:
    Orange City, FL
    Map
    Just purchased 2010 dct model. Should the numbers on the gear readout always be flashing, even while driving? Runs and shifts perfect from my 2 hour 100 mile ride back home with it. Please tell me something is not wrong with my new (to me) bike....
     
  2. som2002

    som2002 New Member

    Country:
    United States
    Joined:
    May 26, 2018
    Messages:
    13
    Likes Received:
    4
    Trophy Points:
    3
    Location:
    Orange City, FL
    Map
    So it looks as I am the only one that has/had this issue with their DCT? Not sure if I should be concerned as it shifts and runs fine. But I don't want to be doing it damage should it be some sort of warning...
     
  3. squirrelman

    squirrelman Member

    Country:
    United States
    Joined:
    Jul 27, 2006
    Messages:
    7,572
    Likes Received:
    106
    Trophy Points:
    78
    Location:
    Buffalo, NY
    Map
    read all 456 pages of the service manual and your question will be answered. :eek:
     
  4. tomcatek

    tomcatek New Member

    Country:
    Poland
    Joined:
    Feb 26, 2016
    Messages:
    14
    Likes Received:
    6
    Trophy Points:
    3
    First check the error codes. Both from the ECU and from DCT. This should give you a little hint what's wrong.
     
    som2002 likes this.
  5. som2002

    som2002 New Member

    Country:
    United States
    Joined:
    May 26, 2018
    Messages:
    13
    Likes Received:
    4
    Trophy Points:
    3
    Location:
    Orange City, FL
    Map
    Well, the ECU is on it's way to Guhl for a reflash, so that isn't going to work...lol.
     
  6. som2002

    som2002 New Member

    Country:
    United States
    Joined:
    May 26, 2018
    Messages:
    13
    Likes Received:
    4
    Trophy Points:
    3
    Location:
    Orange City, FL
    Map
    Ok, I jumped the diagnostic port with a paper clip, brown to green wire. And I get a 12 and a 61 code. Any ideas? I'm reading 12 is a fuel injector #1, and 61 is an ABS voltage...So possibly a dying battery.
     
    Last edited: Jul 20, 2018
Related Topics

Share This Page