ABS Light keeps flashing while riding?

Discussion in '7th Generation 2010-Present' started by Akshay Dabholkar, Mar 7, 2020.

  1. Akshay Dabholkar

    Akshay Dabholkar New Member

    Country:
    United States
    Joined:
    Mar 2, 2020
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    So the solid light goes away when I start riding. Then on braking the lever pulses while it is off. And then after a while it starts blinking and pulsing stops indicating ABS is disabled. Seems like the pulsing on braking is some ABS malfunction. Forums report if the battery doesn't have enough CCAs, ABS can malfunction. The new battery is causing this?
     
  2. raYzerman

    raYzerman Insider

    Country:
    Canada
    Joined:
    Dec 3, 2019
    Messages:
    807
    Likes Received:
    270
    Trophy Points:
    93
    Location:
    Millgrove, ON
    Map
    The pulsing may be ABS kicking in.... check the wheel sensors that they are clean, not corroded, connections OK. Perhaps uneven wheel signals are making the ABS think is has to pulse the brakes. Battery voltage might have an effect on ABS, but usually low voltage (less than 12.8 on some bikes) will mean ABS won't kick in. CCA's shouldn't have much to do with it at all... charging voltage OK?
     
    Akshay Dabholkar likes this.
  3. Akshay Dabholkar

    Akshay Dabholkar New Member

    Country:
    United States
    Joined:
    Mar 2, 2020
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1

Share This Page